Windows Disappeared from GRUB after installing Fedora

Alternate Title: A Grand Olde Tale of Drives, Mount Points, and GRUB, Told in the Fashion of A High Adventure

The Setting: I had been dual-booting Windows 10 (for some school-specific apps) and elementary OS for a little while.

The Departure: However, having grown malcontent (okay, “discontent” is strictly speaking more accurate, but “malcontent” is such a great word) with being on an Ubuntu 18.04 base (and the limits of Pantheon), I decided to replace my elementary installation with Fedora 33 (XFCE edition, though I don’t think that’s relevant). A bold move for me, considering I’d never attempted replacing a distro alongside Windows.

The Disaster: The USB drive has been flashed with Fedora 33 (XFCE), the OS has been booted, and the Installer has been started. Upon reaching the part where he chooses an installation destination (such great rhyming), our Hero™ picks the Automatic setup option and selects “Make additional space” in accordance with the guide he found on the Unix StackExchange. There are 2 ntfs partitions, and he marks both as “preserve”. Everything else goes automatically, and the installation is successful. After booting into Fedora and tweaking some settings and theming, he decides to try booting into Windows 10, just to see if it works. The computer is restarted. The Grub menu appears… and there is no option for Windows 10. Just a couple of Fedora options (I installed on btrfs).

Alright, all that to say, I need to be able to boot into Windows 10, and I can’t. I can still see all my Windows files on their separate partition, so I know it’s all still there, but there’s no Grub option to boot to Windows. As mentioned, I installed Fedora on btrfs. If there’s any more information I need to provide, I will attempt to do so.

Thanks in advance, and hopefully I brought a smile to your day with my literary antics.

Leoj03

Possibly an update-grub could fix this or at least show you what partitions and OS it finds. On Fedora that command may not work, you might need the ol’ classic grub-mkconfig [parameters go here]

Really, that should have happened when Fedora installed grub in the first place. I have had trouble in the past installing grub from a openSuse install on btrfs missing certain other OS but installing grub from one of the other OS finds them all fine.

Might help.

I’d suggest searching at https://ask.fedoraproject.org/ as well.

Thanks.