Ssh -x command

I was browsing here, and came across Ulfnic’s Terminal Tuesday thread. And while I don’t understand a lot of it, it got me thinking. I have a headless server, but it rips my CDs and DVDs for use with Jellyfin. I had been using the commandline, but couldn’t get the rip I wanted.

Turns out, if you run ssh -x you can then run programs like picard or handbrake-gtk FROM your server but ON your local machine! This helped me try several different audio/video options to get Handbrake right, and let me use Picard to quickly relabel/rename a few CDs that all got uploaded as Title1.mp3 instead of the right name when I ripped it.

2 Likes

Ah, I’ve never tried this before. Cool. The server has to have X11 running I presume.

Woow! :astonished:
Never knew you could do that. Thank you for the info. This will come in very handy!

I’ve no idea. I did some searching to see how to tell if X is running, and it looks like it isn’t. For instance

  $ ps -e | grep x
  319 ?        00:00:00 ext4-rsv-conver
  986 ?        00:00:00 lxcfs

I do have X11 Forwarding yes in /etc/ssh/sshd_config and looking at this post it seems like that is all you need. If I run sudo apt-get install xorg it does find a lot of X packages and dependencies to install. So based on that and the previous command, it seems like it can somehow pass X11 instructions onto my laptop since it’s running X.

Super cool! Thanks for checking that out.