So, what's your Linux week been like?

I was wrong last week, it is no hardware temperature issue. I tried the laptop without bottom plate, I put it on his left side and used my room fan to cool the HDD to 37°C. The system started again at say 80MB/s, but over time it deteriorated, it stopped again for seconds and dropped frequently to 1 digit transfer speeds. The 2003 Pentium 4 (1C2T) finished earlier than the 2011 i5-2520m (2C4T).

I also moved one of my VM datasets using the backup facility from one partition to another on the laptop and that worked correctly. The only difference between the 2 backups is the ssh in between, if it is from desktop to laptop.
It looks like the problem is more severe in large datasets, that incrementally backup 40 to 90GB of VM data, while the dataset are 250 to 450GB in size. I now think about a problem with the buffer handling, it starts to look like problems with buffer space fragmentation. I have produced an ubuntu-bug-report.

Still not enough for Gnome in my opinion, at least not if you are heavily multitasking.
I can remember when I upgraded to 4 GB and thought: Now I can use Gnome 3. It was short lived.


Apparently there’s some weird cut/paste bug that’s due to mutter working properly with wayland but not X11. I’ve confused about where exactly this fits into the framework, but for now I’m using Gnome rather than KDE. I’m managing to open a number of apps concurrently now without it freezing completely. Previously open a browser then try anything else and it would just grind to a halt. Hopefully I’ll be able to invest in new hardware in the coming months. Meantime, I’m on the wrong side of the digital divide, mostly.

I’m sometimes getting this strange bug in Ubuntu 20.04 where the left mouse button on my mouse all of a sudden does nothing. The left mouse button stops working on the laptop trackpad also (or any other mouse I might connect)! A Ctrl+Alt+F1, then CTRL+Alt+F2 will set things straight again. It’s not a hardware problem! It’s a software problem.

1 Like

Very annoying when basics start flaking-out! I wonder if this is a known issue. At least it’s good that switching to a different terminal then back fixes it.

1 Like

I know what you mean. Only two years ago I was still using 4 GB of RAM and up until 2016 I used 2 GB! Now I have a Thinkpad maxed to 8 and another Dell maxed to 16. Other people still use more power. That is why for me being able to run Linux distributions on old hardware is important. It not only saves money, it also saves resources.


Nothing wrong with being behind. Saves money and resources. My laptop, my wife’s and also the kids laptops are all recycled from others that upgraded or threw them away. A couple only had dead hard drives! New SSDs fixed those.
One had a faulty keyboard and a couple had broken screens. All work well now though and have been going 2-3 “extra” years now.

Linux also makes them run much faster than Windows…


I decided to install openSUSE Leap 15.3 on my server over top of the current Tumbleweed install. The installer was totally broken. I tried Rocky Linux and that worked but was very unstable. Very strange for these two distros.

Turns out somehow Ventoy got borked on the USB drive I was installing from. Reformatted, reinstall Ventoy and everything was gold.

Then I try to install nextcloud with podman and there’s some bug with systemd that prevents this from working or something and the patch was merged into a version of systemd that I don’t even thing Leap 15.4 is going to have out of the box. So now I’m back where I was 2 weeks ago where this server OS doesn’t seem to do what I want my server to do. Am I asking too much?

1 Like

I’ve started a new work and I’m so happy. I’m creating a kubernetes cluster on CentOS machines, It will be super fun.


Given the number of pixels that I have on my screens, the odds that a speck of debris would be so exactly positioned that it changes the look of a letter in a document – or creates such a stunning birthmark worthy of wonder on a facial image – are truly astronomical. Yet it seems to happen with regularity. Things I ponder.

1 Like

A lot of work on Saturday, as always I updated my VMs, created a snapshot and did an incremental zfs backup to the 2 backups on my 2011 laptop (2TB) and on my 2003 Pentium 4 (1.21TB) :slight_smile:
I did the update for Ubuntu and its flavors to 22.04 LTS and at the same time Virtualbox introduced 6.1.34 and all that introduced a lot of work and large incremental backups (say ~200GB). In my Main VMs I reintroduced Windows XP Home, because I use it frequently as jukebox. I also updated from 20.04 LTS to 22.04 LTS for Xubuntu and Ubuntu. Before the upgrade I saved the 20.04 LTS version in the vm-archives :slight_smile:
I left Ubuntu Studio for the moment on XFCE and 20.04 LTS. I also left Ubuntu Mate 22.04 LTS in the VBox Test Dataset, I stiil have to decide, what to do with both.

I have a set of Ubuntu flavors I don’t use, but I keep it on the latest LTS release, so I upgraded Kubuntu, Lubuntu, Ubuntu Budgie; Ubuntu DDE (Deepin). The upgrade of Unity Ubuntu 20.04 failed so I rolled it back. Try again later.

1 Like

This week, I debugged an insanely bogged down QNAP storage appliance. The load average was above 500! :face_with_raised_eyebrow:

The Entware package helped me to install sanity-restoring goodies like htop, iotop, pstree, and tmux, which were invaluable to sorting the problem out.

1 Like

I found VirtualBox update broke my KDE Neon Developer installation so I had to re-do it.

Strange week for me. After finding I couldn’t really work-around that cut/paste problem on Plasma under Debian Stable, I’ve had to switch back to Gnome, which I used for years previously. Thankfully it’s not a lot faster and able to function on my very old hardware. I then found that onscreen keyboard wasn’t working under Wayland, so have had to fall back to Gnome under X, which is what I was using two versions of Debian Stable ago!

I do love Plasma and am continuing as a bug triager for KDE but I haven’t had time to try a fresh install of Debian Stable based on Plasma as the primary desktop. Apparently it’s mutter that’s incompatible with cut and paste in Plasma on some installs, so maybe that’s why I’m having these problems? Haven’t quite figured out the stack of technologies behind all of this and no time right now to do-so in detail.

I watched a couple of favourable reviews about LMDE 5, and decided to give it a try.

I tried out LMDE 5 on a spare M.2 SATA drive (in an USB enclosure), and so far I’m liking it. So far I like it better than Ubuntu 20.04 (which is my current daily driver, and I’m considering switching more long-term).

I save about 1GB of RAM (with LMDE 5), when the desktop is idling, for starters. The Cinnamon desktop also has a more crisp responsiveness, on my somewhat middle-aged, 4-5 year old laptop (8th gen i5).

With the impending EOL of security updates for Debian 9 (around 30th of June), I finally got around to updating our mail server from Debian 9 → 10 → 11. Since I use mailcow, which uses docker there weren’t any serious issues other than the upgrade to 10 installing Exim mail server and preventing my postfix container from starting! Removing Exim fixed the issue.

Other than that, I have been playing with using Fossil for my local code repos and mirroring to Git when needed. So far I think I am liking it. Every project in one file, with its own wiki and issue tracking - so all the notes for every project stay with the project and full access when offline too.

1 Like

LMDE 5 quickly outshone Ubuntu 20.04. So I switched the M.2 drive in my USB enclosure, for the M.2 drive in the laptop. This effectively swapped LMDE 5 in for Ubuntu 20.04. Could the laptop boot straightaway from the M.2 drive being in a new place, being inside the laptop? Yes! No need to do a grub-install from a rescue media. Moments like this make Linux so worth it.

And could the Ubuntu 20.04 install boot from the USB enclosure (in case I ever need to go back to my old Ubuntu install to retrieve something which I didn’t migrate to LMDE 5)? Again, Yes. No need for a grub-install there either. So profoundly dope!! :grin: This switcheroo of the M.2 drives went as simply as I could have possibly asked. Sssh, don’t tell Microsoft or they’ll figure out how to break this in the future. :wink:

BTW: migrating data from the old Ubuntu install to LMDE 5 was a joy as well, since I just used “cp -a” to copy whatever I needed from the old install straight to the new install. That “-a” preserves file ownerships, permissions, etc. perfectly.

I was able to mount the BTRFS subvols of the old Ubuntu install from within LMDE 5 (on /mnt/tmp) using commands like the following:

mkdir -p /mnt/tmp
mount -o subvol=@ /dev/sda2 /mnt/tmp
mount -o subvol=@home /dev/sda2 /mnt/tmp/home/

I’ve been using LMDE5 on a PC in my living room for a few months now and I love it. I only use it to watch the odd live stream or my kids use it for looking up Zelda walk-throughs or their chores list on Nextcloud (made convenient for them with Mint’s Webapps), but it’s really great. I do like the auto-update feature LM added recently. Might switch my LM 20.3 system over to it.

I’ve been messing around with setting up a proper server and have been shopping around different distros. I finally settled on Ubuntu server 22.04. I like the installer, simple and fast. From there I setup Nextcloud as a snap. I struggled a few times to get it figured out manually but using the snap just worked. So I’ve downloaded all my photos from Google and put them on the Nextcloud, along with syncing my phones photos, contacts and calendars. Next I’d like to figure out a way for Nextcloud to handle a complete phone migration from a G-Apps based Lineage phone to a de-Googled Lineage phone.

It’s also running a Unifi controller since I just received a second hand AP but I’ll be integrating some P2P units and cameras in the near future. I’m happy with the device but their software is kinda crap. I could not “adopt” the device into my system with any browser based tools on Linux or Windows and had to use the Android App to do it. Then later on I had to SSH into the device but found their documentation pretty poor about it.

I’d like to get the server running Jellyfin as well, maybe I’ll try that one in a container to figure out how that works.

Also managed to flash an Asus router with Fresh Tomato via Telnet rather than the Windows only recovery tool Asus provides. Worked a treat!

1 Like

It’s been greeeeeate !

1 Like

For those of you who remember me you’ll know I am a keen distro-hopper. As of yesterday I finally put Fedora and my number 2 laptop. So now I am now running Fedora 36 on 3 out of 4 computers I own. I just can’t find any experience I prefer to Fedora right now. So I guess I am officially no longer a hopper. It’s all good, it’s a choice. How about that.