Remarkable - Help me Obi Wan Kenobi, you're my only hope

Hi friends,

yes, you really are my only hope. I tried this myself for 2 weeks now, and I failed:

I use and want to use the super markdown editor “remarkable”:
https://remarkableapp.github.io/

It worked perfect on Kubuntu 18.04. But on 20.04 (no matter what flavor of course) and also Debian 10, the deb-file is not installable, because of dependency issues. No chance.

Then, even the dev says on github, that he wants to target the snap format. That would be ok for me, but the snap (remarkable v. 1.87) does not work on (K)ubuntu 20.04. I can install it. I can start the program, but its main purpose is to export in pdf or html. And both operations fail.

I checked a lot already, and I thought that apparmor could be the reason. But I am totally not familiar with apparmor, so I could not figure out IF it is the cause and how I could fix it.
I tried to start with grub-parameter “apparmor=0”, but with no success.

My great hope is, that some of you guys can figure out, how to get this program to work under 20.04.

If you want to test it: Just open the snap program remarkable, and choose to export to PDF (styled)… even an empty document. Then the error message appears: “PDF Export was not successful”.
Also HTML export does not work.

If someone is out there that could help me fix this - you would be my hero and my jedi-master-of-all-times

You can also reach out to me via mail or telegram:
Mail: pragomer@posteo.de
Tg: @pragomer

Kind regards

This seems to be a problem with how the snap was built. You’ve peaked my curiosity (this looks like a great app), so I’ll look into it myself. https://github.com/jamiemcg/Remarkable/issues/338#issuecomment-632303094

Hi WalJT,

peaked sounds great… as I have no knowledge about building snaps or so.
But yes, you have seen that right: The app is really so so great… you could test a working version under Ubuntu 18.04 or Arch or so…

If you could find out how to solve this or find a workaround, you would literally save my year 2020 :-)… because: I also just discovered the app in March… then was happy that 20.04 was released… yes, and then sad because the deb wouldnt install… and the snap did not work either…

I really hope you can get any further… and I would be so so thankful.

1 Like

I’ve somewhat fixed the issue. It more or less boiled down to missing dependencies inside the snap. I’ll create a pull request and see if the developers will accept my changes. If they do, then a future update of the snap should fix the issue.

1 Like

Just in case, did you try an apt install -f? That usually tries to satisfy all dependencies if you install a .deb file by hand with dpkg.

Wow… that sounds great…
I have to ask like a total noob as I am totally not into software development… is the creator of the snaps the original dev of “remarkable” or did someone different create the snap?

I also thought about learning someday how to create appimages, because I think it could solve such an issue if I was only able to create one…

Saying that you somehow fixed it… is there a workarround I could do to get it to work under my system?
I tried things with apparmor… was this the problem?

Hi,

yes, I tried that. I know about apt install -f, and very often this really helps.
But unfortunately in this case, it didnt.

Oh, WalJT,

I read, that you wrote on github you “try to create a snap locally”.
I case it work… could I somehow try to use it? Or does this not work as simple as copying a single appimage file… :sleepy:

I’m not sure. There is a snapcraft.yaml in the git repo for the project, but I don’t know who actually maintains the snap.

The issue was a missing library inside the snap, so the workaround would be to build the snap locally using a custom snapcraft.yaml file (which I’m trying to get accepted by the developers). The process for this would be:

  1. Install snapcraft and multipass on your system
  • snap install snapcraft --classic
  • snap install multipass --classic
  1. Clone the git repository
  • git clone https://github .com/jamiemcg/Remarkable.git
  • cd Remarkable
  1. Replace snapcraft.yaml with this file
  2. In the Remarkable directory:
  • run snapcraft (this will build the snap… it takes a while)
  • install the snap with snap install ./remarkable_0+git9024df1.snap --dangerous

There’s another issue though, where the live preview now doesn’t work. I don’t know if this is a result of my changes, or something that changed in the upstream code. PDF exporting works with those changes anyway.

Ps. Here’s the pull request relating to this issue.

1 Like

Hi,

I tried. When running snapcraft, I get the following error message:

Issues while validating snapcraft.yaml: mapping values are not allowed in this context on line 114, column 73

Any idea?

Yaml is super picky. If you didn’t put tabs / spaces for indentation perfectly, it will barf like this.

Hi popey,

would you have any tip for me, how I - as a non-dev-person-and-just-a-user - could get this snap to work?

Just a quick update, there’s no response from the developer on my pull request yet. Probably they have more important things to worry about, which is perfectly reasonable. Since I’m familiar with Python and have some spare time, I’m going to poke around in the code and see if I can fix some other issues.

I could have introduced that problem… I just copy-pasted the modified snapcraft.yaml into the pull request fork.

@pragomer I just tried out Zettlr, which was mentiomed on the latest episode of Linux Unplugged.

Looks amazing and seems to work really well. It does need a bit of work to get PDF export working. It needs LaTeX (which I had a lot of installed already) and the Microsoft fonts (the ttf-mscorefonts-installer package in Ubuntu.)