Problems with setting up full disk encryption

I also use a paid VPN and got some nice add-ons in firefox, but it seems i have things to learn. I’ve read some very nice tips here.
One thing though, i’ve never been able to encrypt my disk. Every time i try, i can’t log in. What am i doing wrong? I go through the install process, select the option to encrypt the disk, continue with the setup and that’s it. It’s been a while since i’ve tried it again.
Any tips would be greatly appreciated.

I’ve encrypted my disks, but it doesn’t really provide me with much security as I never shut down my laptops. I just lock the screen and keep them plugged in.

The just open a support thread on the issue and I am sure someone will chime in. :wink:

2 Likes

The more information the merrier, few questions to start…

By “i can’t log in” do you mean at the graphical login prompt (LightDM or similar)?

By encrypt your disk are you selecting full disk encryption or home folder encryption?

I’ll try to be more precise. After the setup has been completed, and the system boots, i need to type in my password, in order to unlock the disk.
That’s where it goes wrong, my password isn’t recognized. That being said, i’ve just thought of something. English is not my first language. It’s Flemish. (I’m from Belgium).
During install, i always set my keyboard to Azerty, instead of the standard Qwerty. (My keyboards have always been Azerty.)
Could it be that the default keyboard input would be in Qwerty, instead of Azerty, when trying to unlock the disk?
Come to think of that, i’ve never tried that before. Typing the password as it would be on a Querty keyboard.
I always assumed it would be Azerty, because of my settings earlier on.
Could it be that, or something else?

Thanks for the help!

I think you might of got it there. I’m always on US keyboards so i’ve never encountered it.

From the SUSE documentation on Grub2:

Important: Keyboard Layout During the Boot Procedure

The US keyboard layout is the only one available when booting. See Figure 41.2, “US Keyboard Layout”.

https://documentation.suse.com/sles/12-SP4/html/SLES-all/cha-grub2.html

1 Like

facepalm
If i only knew that earlier on… (Why didn’t i see that?)
This makes me feel so stupid. But then again, another day, another thing learned.
Always check the documentation, or, rtfm.

Thanks for the help!

A simple mistake anyone could have made. Glad you got it fixed.