Play Netflix w/Firefox, ! Error Code NSES-UHX ! Error Code F7355

Hi all,
I am hoping that @MichaelTunnell will weigh on in on this thread because well . . . Firefox:)

Now, I am trying to use one browser for everything that I am doing and Firefox is great. I just have one problem. For some reason, randomly and with different distro installs (PopOS, Fedora, CentOS), Firefox refuses to play stuff like Netflix (Netflix stating “Something went wrong . . . Sorry, we’re having trouble with your request. You’ll find lots to explore on the home page . . . ! Error Code NSES-UHX”). The error code seems to be random as well until I refresh the page and get Error Code F7355. I know that I have to enable DRM in preferences and I did but that just does not resolve the issue. Is it possible that my selection did not register in the GUI? If so, is there a way to do this on command line? Perhaps I can install a package that would make sure that I always have this capability? Some suggested installing Chrome but that seems to contradict the point of using Firefox. May be installing Chrome is the easiest/only way but maybe not. Any suggestions?

Calling for Michael is a bit like calling for Superman, he’s off making the World safe for Linux so the community tries to answer things before he gets back. :stuck_out_tongue:

Very strange you’re getting random outcomes, NSES-UHX didn’t come up with anything but for F7355 there’s some advice to clear your cache…

“Clear your Firefox (version 52 or higher only) caches by going to Preferences, Advanced, Network tab, and click the Clear Now buttons, shown below…”

https://askubuntu.com/questions/906815/netflix-error-code-f7355-1204-and-f7363-1260

There’s more suggestings in the comments, i’m afraid I haven’t had this issue myself.

You could also try Chrome or Chromium if only to see if they share the problem.

2 Likes

Hi @Ulfnic,

Michael is Superman so he will eventually get there :). I did try clearing the cache but no luck. I also saw the post you linked. I do see that it says versions 52+ put version 52 to version 74 seems to be like a lot, no?

For me, installing vlc and mpv always resolves Netfilx issues since they pull in the correct audio and video dependencies. I have been to lazy to pin down the exact packages that resolve the issue but, just try installing vlc and mpv and you should be good to go.

You have to install the third party codecs for Firefox to work with Netflix. I am not well versed on the Ubuntus in this regard but for reference, you can use this and pull down the similarly named packages for Ubuntu from my openSUSE reference. If you need more clarification, just hit me up and I can try to break it down further.

Good point however, installing the third party codecs in the recommended way for the distro does not always work. For example, on Fedora and CentOS, you would enable RPM Fusion and install the multimedia package group from there (instructions on the RPM Fusion site for installing the package group) but, netflix still won’t play. If you install vlc and mpv, they will pull in the needed multimedia libraries and you should then have no problems watching netflix. I can also confirm that I just installed vlc and mpv to get netflix to work on PopOS without any other fuss.

I would probably try to install some of the missing codecs from Ubuntu’s repositories, that you could also install under Debian. Though I thought it is not necessary and probably the error you have is something else.

There is a meta package called libavcodec-extra. That is also what probably gets pulled in by installing Mpv or VLC but I am not sure.

I can say for sure it is required to install extra libraries and codecs for netflix to work on PopOS which is the only Ubuntu related distro mentioned in the original post. I cannot vouch for Ubuntu proper or Debian proper for that matter since it has been a bit since I have run those. For PopOS, the easiest way is to install vlc and mpv. For Fedora and CentOS (the other distro’s mentioned in the original post), I always enable the RPM Fusion repos (free and non-free) and then install vlc and mpv.

One final thought from me… If you have an aversion to outright install vlc and mpv, then you might take a look at the dependency list each one of them pulls in and only install the ones you need to make netflix work. This is the part where I mentioned I was to lazy :slight_smile: You can see the dependencies easily from the Arch Linux website but, you would have to figure out what they are named in the distro you are using. For VLC you can see them here: https://www.archlinux.org/packages/extra/x86_64/vlc/ and for mpv, you can see them here: https://www.archlinux.org/packages/community/x86_64/mpv/

Hope this helps! :slight_smile:

Do you have the Cisco plugin installed?

Do you have any extensions in Firefox that might break stuff like NoScript, ublock origin, etc?

Hi @charlesDelaware,

sorry for the late response. Many thanks. I just tried it on a VM installing MPV along with VLC from the RPMFUSSION repo seems to work. Now have to check my other machines.

Also, this does not seem to resolve the issue with PINEBOOK PRO notebooks as that is running ARM.

Hi @CubicleNate,

thank you very much. Looking at it now.

1 Like

Hi Michael,

thank you so much for your response. I do have the Cisco plugin installed. I have a number of machines and I think that it actually may be enabled on one of them. Will check when I get home. In as far as I can see, I do no have any other plugin except for BITWARDEN. I did installing VLC and MPV and that seems to work for the machine that I am on right now (Fedora 30) as well as a Fedora 31 VM. So, should Cisco be disabled?

Also, would you or anyone happen to know how PINE gets it to work or is that completely different because of Arch and ARM?

No problem! I don’t currently have a Pinebook PRO to troubleshoot but, I did come across this thread that you might keep tabs on : https://forum.manjaro.org/t/firefox-widevine-plugin-to-watch-netflix-on-pinebook-pro/119922 Looks like an unresolved widevine issue at the moment

Plugins and Extensions are different things in browsers. Bitwarden is an extension not a plugin for example.

No, the Cisco plugin is a requirement in order to have Netflix work. This is a DRM decryption plugin made for Firefox by Cisco, it is officially recognized as the solution for Firefox.

If you have the plugin installed then you need to also make sure you have the setting to use it enabled.

Digital Rights Management (DRM) Content option needs to be checked in order for Netflix and any services like it to work. Go to your Firefox Settings -> General Settings -> check the box that says "Play DRM-controlled content.

image

Strange. I have that plugin disabled and never used it.
Of course I have DRM decryption enabled and Netflix works here.

i also got the ‘NSES-UHX’ error code and it just resolved when i closed firefox and opened it again. i also cleared the cache before but that didn’t help.