Pine64 Smart Watch Now Available

Mine must be on a slow boat from China.

1 Like

Mine shipped a week ago but even today it shows that it’s still in China.

1 Like

I also got mine yesterday.
I am really impressed by this $27 watch. :wink:

4 Likes

agreed… I just don’t understand why shipping to Canada is so expensive. We are not that far away. lol

I also payed more for shipping than the actual watch. :wink:

1 Like

I’m impressed so far too!

2 Likes

Received my watch today. Order time to in hand on wrist was 21 days.

Charged it. Loaded up gadgetbridge from fdroid onto my old Note 4 with Android 6. Verified the firmware and boom goes the dynamite. It paired and connected simultaneously with my bluetooth earbuds.

4 Likes

Just ordered mine today! Can’t wait! Thanks for this post or else I would have missed it.

2 Likes

I have been unable to keep the connection to Gadgetbridge active. Do you do anything special, or do you have the same issue as I do. The connection seems to hold for a few hours, then disappear and I have to re-pair the devices again.

I’m joining in on the hype. Can’t wait for mine to arrive.

In GB there is a checkbox for “Reconnect Automatically” which is under the “hamburger” → settings → “reconnect automatically”. That fixed most of my problems but twice I had to reboot the watch (long-press on the side button) to get it to connect. This has happened after I left my phone for an extended period of time and upon returning, I had the re-connect issue. I’m thinking that it needs to to be a button to make it “discoverable” as it seems that once it’s paired, it doesn’t announce itself.

1 Like

Okay, so I’m not alone with that issue.

Have you tried updating InfiniTime to 1.3.0?
I tried, but was not successful. Gadgetbridge did not even recognize the file as a firmware file and nRFConnect, would tranfser the file, but the PineTime would just display “Error” when the transfer was done.

Okay, tried updating the firmware again. This time I was successful. Running 1.3.0 now. :wink:

1 Like

Nice. I’m going to do the same – still on 1.2 here.

Mine came to day. Had to connect and disconnect it a couple of times to sync with GadgetBridge.

4 Likes

I am running the 1.3.0 firmware since about two weeks and I have also experienced some connection issues (paired with a samsung S20 FE).

Pairing with gadgetbridge was easy and bluetooth connection is generally good. Although, I find that if the watch connection was lost or it disconnected due to distance with the phone the reconnection option in gadgetbridge rarely works for me. I had minor success by using the quit button in gadgetbridge and restarting the app. If not, a watch restart always does the job.

My battery though seems to charge up to 89% max, anyone has the same issue?

Sharing :grinning: Just out today Infinitime 1.4.0 !!

I’ve updated my pinetime to 1.4.0 and the touch screen is definitely more snappy. Can’t wait to see if the fix for the battery status will show 100% on my next charging.

Also nice to be able to customize the PineTimeStyle watchface colors

2 Likes

I’ve been trying to update mine all morning. Still haven’t succeeded though.

Updating the firmware is very hit’n’miss for me.

Siglo works very well for me.

Siglo Flatpak

Sorry to hear that.

I used Gadgetbridge V.0.59.2 and it went smoothly (maybe I was lucky)

Freshly updated to Gadgebridge v.0.59.2 and InfiniTime 1.4.0 (Flashed the firmware with Siglo)

Attached to Galaxy Note 4 Android 6.

After the first 6 hours, connectivity issues are much, much better.

1 Like