Laptop Display not Detected

I was using two external monitors and the laptop display for a total of three monitors until a kernel and Nvidia driver update caused a series of issues. Currently only external monitors are detected and work fine, the laptop display doesn’t.

  • Distribution & Version
    Fedora 31 and Gnome 3.34.1 on System76 Oryx Pro 5 (Nvidia GeForce RTX 2060 - Nvidia Driver 440.36)
  • Kernel information
    Linux oryx 5.3.13-300.fc31.x86_64 #1 SMP x86_64 x86_64 x86_64 GNU/Linux
  • When did the issue start happening?
  • Did anything change that caused it? (hardware change, upgrade)
  • What steps do you take that cause the problem?
    After a kernel and Nvidia Driver update on Fedora 30, the system was booting to Intel Driver only.
    I updated to Fedora 31, no change.
    After another kernel update, the system would not boot into graphical user mode, I received the error “NVIDIA kernel module missing, falling back to nouveau” but system was stuck there, all I could do was ctrl+alt+del to reboot. I booted into runlevel 3 and updated the kernel again and I was able to boot into graphical mode again now. But the laptop’s display is not working. During boot the laptop display works, I enter luks password, see grub menu, see Fedora logo and spinning wheel, but once it is time for the OS login, the screen goes black with a cursor in the top left corner. If I connect an external display the login prompt is there waiting to login.
    output from xrandr with my two external monitors connected:
    $ xrandr
    Screen 0: minimum 8 x 8, current 3360 x 1080, maximum 32767 x 32767
    DP-0 disconnected (normal left inverted right x axis y axis)
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
    1920x1080 60.00*+
    1680x1050 59.95
    1440x900 59.89
    1280x1024 60.02
    1280x800 59.81
    1280x720 60.00
    1152x864 75.00
    1024x768 70.07 60.00
    800x600 60.32 56.25
    640x480 59.94
    DP-2 disconnected (normal left inverted right x axis y axis)
    DP-3 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 408mm x 255mm
    1440x900 59.89*+
    1280x1024 75.02 60.02
    1280x960 60.00
    1152x864 75.00
    1024x768 75.03 70.07 60.00
    800x600 75.00 60.32 56.25
    640x480 75.00 59.94

Personally, I’d just contact System76 support. I’d help, but I can’t replicate your setup so that would be your best bet. Let us know what the solution is, in case anyone else runs into this issue.

1 Like

I am not an expert with graphics but I would try to login with an external monitor and when you are at the login screen I would select the Gnome session using Xorg rather than the default Wayland and then try it with the laptop display. You can find that option in the cog wheel from the login screen under the user name.

They only support PopOS and Ubuntu unfortunately.

The options I have are Gnome and Gnome Classic, I tried both but had the same result with each.

Also not a graphics expert but interested if you get laptop display if you start the system from a PopOS live USB, maybe worth comparing kernel modules loaded etc between working and not working. :man_shrugging:

Could be that on Fedora the X session is no longer available. But in your case it seems it would not make any real difference. I think the problem here is more serious.

The screen is detected on a Pop live usb as well as a Fedora 31 live usb.
How would I go about comparing the kernel modules?