KDE Plasma help dialog every restart

Hi everyone this forum is looking awesome!. I love it thanks for having me here

I’m having an issue or bug with KDE Plasma 5.16.5 running on Arch. This happens in Kubuntu as well

I’m getting this dialog box every time I restart or shutdown pc I’m running dual screens. Not sure why it comes up everytime I don’t want it to if @MichaelTunnell can help that be great anybody else knows how to fix this also let me know thanks.

here’s what the dialog looks like I hit the red X but every restart or shutdown it comes back up.

imagebam.com

I think you should set a default in the monitor settings but I am no Plasma user. So that it does not ask you every time. But I guess @MichaelTunnell will know better. :wink:

Thanks, @vinylninja I had it set to a primary display the monitor I’m using. That dialog keeps coming up

Unfortunately I cannot remember how I was doing it because I had the same problem when I had Plasma installed.

1 Like

Ok so I had this issue to at some point and I do not remember how I fixed it. I think it has something to do with a Primary Display not being set. So if this is correct for you then go to System Settings -> Display and Monitor -> Displays, here make sure that Primary Display is set to what you want it to be. I think if it isnt set it will constantly ask without selecting a primary.

If it is already set try changing something in here and the click Apply. I think this will solve it by regenerating a config file from the System Settings tool and stop that from happening.

Please, let me know if this helps.

1 Like

I don’t know if this will help, but it was a vid I made when I kept losing my primary monitor. It’s for Manjaro, but should apply to Arch, since that’s where I got the help. Don’t know about Kubuntu. Plasma wasn’t saving things for me. https://www.youtube.com/watch?v=MrcMyHHglyQ

Note: For nVidia, so not sure about AMD in this area

1 Like

Never experienced this issue, but I wanna try and help. I have couple of questions:

  1. What GPU are you using?
  2. Is this a laptop or a desktop?
1 Like

Thank you @MichaelTunnell I actually did pick my Primary Display System Settings -> Display and Monitor -> Displays. And the panel was set back every time to the wrong display. However, I think I figured it out. Tell me if this is right. When the dialog comes up for your display I think you have to pick which side the panel will go on. It also has Mirrors option which I don’t normally do. I don’t know what I was thinking. I think I thought it was going to do something else. Let me check again before I had Feren Next Beta based off Kubuntu I was using that. I did, however, boot LiveCD off Kubuntu just to see if it did the same thing and it did but I don’t think I installed it. I also installed Arcolinux KDE and did the same thing. Now I’m on Manjaro KDE I picked the main display I was using for the panel to go on the left side when that dialog came up if you’re facing the screen.

I’m going to install Kubuntu on another SSD I have let you know if that’s right and fix’s my issue

I’m on Desktop PC old build I did i7 2600k. looking to save up for ryzen. GPU I have is RX 590 AMD Card. @YamiYukiSenpai

I was using Nvidia before it was GTX 760. which leads me to my next question I noticed AMD cards are different when I was using HDMI on Nvidia card my main display was right. But on AMD I think they want you to use Displayport as #1. When I install other Environments panel is on the wrong screen.

Thank you, everybody, MichaelTunnell vinylninja AJM YamiYukiSenpai for helping me and really enjoying the new DLNetwork