I am an idiot: AMD openCL & darktable

turn out I had to manually install from manjaro repo the opencl-mesa package… now darktable is much much faster! Thanks to a stranger on the internet replying to a youtube comment I left saying how much slower darktable is that lightroom. Thank you kind stranger. Video here: https://www.youtube.com/watch?v=EZVqd0BJEfs&lc=Ugzi-NUmHZTckjuL27Z4AaABAg.96H1duUdeZc9GbPlSXdNHY

Heh just noticed youtube still has my real name… I guess left over from G+ as I wouldnt have changed it after that. Meh whatever.

4 Likes

sooo… this took a LOT more work than just installing opencl-amd from the manjaro repo. I thought I had enabled this but turns out I had not! Placebo, much?

I had to get the AUR one in the end as darktable would not recognise the 5700XT as a valid openCL device, and failed to enable openCL on startup.
I ran darktable -d opencl to see what it was doing.

After a LOT of searching online as there’s not a lot of info on doing this in Manjaro/Arch, I installed the AUR version of opencl-amd and then re-ran darktable… and it’s enabled yay!

Much faster. :smile:

4 Likes

Thank you for sharing the progress, i’m glad you got it working. These hardware issues can be tricky.

1 Like

Ok so maybe hold that thought - did an update and rebooted and now xorg cant see any display/screen device :man_facepalming:

Luckily I dual boot, so can revert to the old WIn10 disk; and the files I need I have on a shared ntfs drive so I can carry on working until I work out WTF I screwed up.

update: I may have added /etc/X11/xorg.conf.d/20-radeon.conf - which I removed and it booted… damn you Arch Wiki and all your options on how to do things. :laughing:

So yeah, opencl wil be fine, and I am still an idiot :grin:

That is how I have had to get OpenCL working too. I wish RawTherapee could use it as well.

1 Like

Can confirm aur/opencl-amd is needed for dt to access GPU.

1 Like