Fix screen tearing on Xfce (openSUSE Tumbleweed)

My trial with openSUSE runs fine for the moment but I had my first hiccup.

I use Xfce and normally I always add compton as compositor because xfwm4 still presents me with screen tearing on video content regardless of the options outlined in the window manager tweaks. I have an Intel integrated graphics card and that was always an issue on my machines.

Compton is in the Tumbleweed repos but was replaced by picom after an update, expected to happen on rolling releases. I probably should have installed picom from the get-go. As compton is no longer actively maintained it was supposedly replaced by picom by my first update to another snapshot. No problem I thought but I could not configure it to work like compton and get rid of screen tearing, no matter what option I tried from the man page.

I found the solution by looking at the Arch Wiki. I had to switch the back-end to glx via xfconf.
You can use the Xfconf editor or the terminal:

xfwm4 --replace --vblank=glx &

Basically Xfce itself can solve the problem but I was never aware of that option and used an external program. There is no longer a need for that, at least in my case.

I hope it is useful to someone else.

Reference

2 Likes

That is a very cool solution. I haven’t had tearing in Xfce on the machines I have but they are super old netbooks. I also thought that the glx vblank option was just a click away in the settings but I could be totally wrong on that.