Easily Install JACK Audio with Ubuntu Studio Installer

Originally published at: https://frontpagelinux.com/tutorials/easily-install-jack-audio-with-ubuntu-studio-installer/

2 Likes

Ubuntu Studio leader here. Great tutorial! I’ve linked to it on the Ubuntu Studio Installer page Another thing that can be done is PulseAudio can be totally disabled or bypassed while using OBS’s built-in Jack clients.

2 Likes

Hello, thank you so much for your kind words. I really appreciate that.
Ubuntu Studio is amazing. Not only it is a great distribution, but you guys even make it super easy to install all the Ubuntu Studio tech in any Ubuntu Flavor. How awesome is that?

Thanks for your great work!

1 Like

Hello! I just read through the tutorial and I’m trying to get my audio setup with JACK working on Ubuntu 20.04. I installed Ubunto Studio controls and the program launches perfectly, no issues there. I’m just confused on how to best choose the Jack Master Device and USB devices. Here is my setup:

  • Laptop: Dell XPS 9300 developer edition
  • Laptop is connected to a Dell WD19 Thunderbolt 3 dock
  • XLR microphone connect to a Focusrite Scarlett Solo USB mixer. The mixer is then connected via USB to a Dell WD19TB
  • Logitech H600 wireless headset (USB) which is connected to a simple USB hub that shares my keyboard and mouse. That “hub” is then connected to the aforementioned WD19 Thunderbolt 3 dock

The options available in the Jack Master Device show the following:

  • default
  • USB Jack Master
  • PCH,0,0 playback and capture (ALC289 Analog)
  • 4 other options corresponding to different HDMI settings (format PCH,X,0 playback (HDMI X)).

For the USB device that should be Master option, choices include:

  • No USB Master, USB 0,0 playback and capture (USB audio)
  • Dock,0,0 playback and capture (USB audio)
  • Dock,1,0 playback and capture (USB audio)
  • Headset,0,0, playback and capture (USB audio)

I’m still really new to JACK, but is there any guidance or tutorials on how to map multiple USB-connect devices together like in my setup?

Hello,
If you have multiple devices to connect to jack you can do so without issues:

  1. First, select your master device. if it is an USB device, select Jack Master device: USB Jack Master. Then below it, in the USB device that should be Masster: select your USB device. At this stage I recommend you to try and connect all usb devices directly to your PC. It will make things a bit easier to start with.
  2. After you have your main device connected, you can move to Ubuntu Studio Controls, Audio Setup, Extra Devices. In the Connect Other Internal Audio Interfaces. From the Add dropdown, select the interface you want to add.
  3. Stop and Restart Jack.
  4. Then OpenQAS Mixer and on the right, select the interface, set volumes.
  5. Last but not least, open Carla, you will find your new devices in the patchbay. You can then choose interfaces, drag your connectors according to what you are trying to achieve.

Please note if something is not working right away after adding devices to jack, do not panic. :slight_smile:
Close Carla, stop Jack, and restart Jack. If that is not enough, you can try and reboot your pc.

I hope this helps.

Cheers,
Mauro

Hey, first post here after following the great article and the comments.

After following the guide on Ubuntu Mate 20.04, I have a minor but quite annoying problem:

After each reboot, all output channels (Master, Speaker, Headphones) are muted. :hear_no_evil:

To hear sounds again, I have to open QASMixer via Ubuntu Studio Controls and pull the channels up again.

I have to use the “Open QAS Mixer” in Ubuntu Studio Controls -> Audio Setup. If I open QASMixer from the Menu only see limited controls: Two channels for Master Out and In
(Sorry, can just post one Screenshot)

Is there a way to preserve Mixer Settings across a reboot, by changing a configuration value somewhere? :thinking:

Greetings from germany,

Markus aka Krok

3 Likes

Hi,
I also noticed something similar, and found an open bug. I added my input, feel free to also have a look and report there.

Hi,

This is no solution yet but my personal workaround:
I’ve written a simple script to push the affected levels to 11… I mean 100%.
At the moment I doubleclick this after logging in, but I plan to let systemd run it for me later on

#! /bin/sh
amixer -c 1 sset 'PCM' 100%
amixer -c 1 sset 'Master' 100%
amixer -c 1 sset 'Speaker' 100%

This tells ALSA (which seems to be at the root of my problem) to set the relevant output values of (in my case) sound card 1 to 100%.

If someone else wants to use this, get the correct number of your sound card with

cat /proc/asound/cards 

your sound card controls may have different labels than mine. Use

amixer -c 1 scontrols 

with the correct number for your sound card after the -c

HTH, Markus

2 Likes

Hello,
Thanks for sharing. Could you also post it in the bug report i shared. More people involved there will definitely draw more attention to the issue. I believe we should ask to assign the bug to ALSA, as the issue is not QASMixer.

If I open QASMixer from the Menu only see limited controls

press F6 to show device selection options on right side

to save mixer settings to be restored on reboot:

sudo alsactl store