Additional Drive Formatting and Permissions

Hello, I use Kubuntu 21.10. How would I grant permissions to an additional drive after formatting it as ext4 without using the terminal? Dolphin is the file manager that I use.

I’m not sure what you’re asking. Could you provide some details as to the permissions you’d like to implement please? (English is not my native language, so i got confused by your question :thinking:)

Quick answer: Gparted can go a long way when it comes to formatting etc…

I’m asking for an example to grant permission to a drive formatted with an ext4 partition.
In Dolphin, when I access the drive with an ext4 partition, creating a directory, file or any
other operation is not permitted. How would I allow myself to perform these operations
without using the terminal?

Damn. I have no idea how to that with a GUI. I hope I can bump the thread for you.

I myself use only the terminal to change permissions on drives.

I’m only posting this because it’s been 4 days.

What’s tricky about this is the terminal is the native language of Linux and the great unifier as it’s usually extremely similar across distros so it’s much easier to get help because you’re usually dealing with the same program(s). The GUI splits people up into one of several interfaces that solve the same problem in one of several abstract, often poorly documented and hard to debug ways.

Strictly keeping to GUI I don’t use Dolphin but I do use Thunar which auto-mounts drives with appropriate privileges (usually) without having to do anything so it might be worth a try if you want to try out a different file manager. If you’d accept a TUI solution, bashmount is really good.

1 Like

Hopefully this will help and is within a useful time frame. Its been 4 days.

Its been a long time since I have used KDE so I installed dolphin (on gnome). But here goes
Linux treats drive mount points like a folder so

  1. Launch dolphin as root. It’s either pkexec dolphin or sudo dolphin
  2. Find drive mount point ( also in side panel) right click and select properties
  3. Click on permissions tab.
    Change for others/group and give them read write and execute via the drop down menu. Make sure you check the apply to subfolders
    This will apply to what ever machine you put the drive into
  4. If you want to get really granular hit advanced permissions
    From here you can edit, add and remove to change everything and it will stick no matter what machine you put it in.
    Screenshot from 2022-02-22 19-23-51

I used this method for a little 2TB external formatted ext4 and that gets passed around among a couple of cousins and a few friends.

Good luck

3 Likes

Thank you, I will try to make this work.

the advice from @RedNekNix is a great way to do it via a GUI. The lack of ability is due to the mount being owned by the “root” user and since your regular user doesnt have ability to edit stuff as root you essentially need to tell it to take ownership as your regular user. This will give you all the management features in Dolphin.

If this doesnt work for some reason you can run the following

sudo chown -R username path/to/mounted/drive

this will give your user ownership. The -R part tells it to do it recursively so all files and folders in the drive take ownership too.

2 Likes

How could this be accomplished in the GUI?

@MichaelTunnell

I think he was refering to RedNekNix’s post as the way to do it in the GUI.

I don’t know of an alternative GUI way other than running your file manager with sudo as RedNekNix described.

2 Likes

Yes, @Ulfnic is correct. I was saying that the information provided by @RedNekNix was a good solution.

The commands pkexec dolphin or sudo dolphin still do not run Dolphin with elevated privileges and thus will not allow me to make any changes to the newly created ext4 filesystem. It’s nice to modify permissions in the properties, but Dolphin will not allow me to even change these settings in the first place.

@MichaelTunnell
@dasgeek
@RedNekNix

I spun up a Kubuntu VM and got this:

image

Switching to the root account and just entering dolphin gives the same message.

Is that the message you’re seeing?

I gave dolphin a go on an Ubuntu 21.04 Gnome VM and got the same error.

Running dolphin as the regular user I attached a memory stick to the VM and I was able to mount it with correct permissions just by clicking on the icon.

image

This seems like a deeper problem because you shouldn’t have to do these permission changes.

If I can get the outputs of lsblk and df -T in terminal it’ll help narrow down the issue.

udisks - ArchWiki

1 Like

I’ve always had this issue in Kubuntu or recently using Fedora 35 KDE. This problem is not new, delevopers have been trying to fix this problem for a while. I’m not sure if Dolphin allows root
privileges at all currently. Well, this is the output in the terminal after trying to execute Dolphin…

sudo dolphin
Executing Dolphin with sudo is not possible due to unfixable security vulnerabilities.

If I could just find a command to execute Dolphin with root privileges, that would be
ideal. For now I will just have to use the terminal to manage data on my drives.
What are you’re thoughts?

@Ulfnic
@MichaelTunnell

I can say that KDE removed the ability for Dolphin to be ran as root for security issues in the code but they are working on putting it back for the next release. This is why running the application with sudo doesn’t work. It will in a few months but not right now.

There are some workarounds like using another file manager for this kind of thing. You can also install a context menu thing for Dolphin but it’s not recommended to do that one usually.

How frequent is this issue experienced?

Every time that I need to modify certain system data. For an example, simply trying to copy a wallpaper to /usr/share/wallpapers/ results in an access denied message. Deleting the wallpaper in that path is
not possible. Do you know which release will add root privileges for Dolphin?

@MichaelTunnell