About running Snaps on Debian testing

Hello,

I do not mean to get political,

I am trying to learn Debian, so I installed it on a very old lend over Toshiba laptop

$$$$$$$$$$$$$$P.       -------------- 
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux bookworm/sid x86_64 
 ,$$P'              `$$$.     Host: Satellite C605 PSC4SU-006TM1 
',$$P       ,ggs.     `$$b:   Kernel: 5.10.0-8-amd64 
`d$$'     ,$P"'   .    $$$    Uptime: 1 hour, 2 mins 
 $$P      d$'     ,    $$P    Packages: 1989 (dpkg), 15 (flatpak), 9 (snap) 
 $$:      $$.   -    ,d$$'    Shell: bash 5.1.8 
 $$;      Y$b._   _,d$P'      Resolution: 1366x768 
 Y$$.    `.`"Y$$$$P"'         DE: Cinnamon 4.8.6 
 `$$b      "-.__              WM: Mutter (Muffin) 
  `Y$$                        WM Theme: Cinnamox-Rhino (CBlack) 
   `Y$$.                      Theme: Cinnamox-Rhino [GTK2/3] 
     `$$b.                    Icons: Papirus-Dark [GTK2/3] 
       `Y$$b.                 Terminal: gnome-terminal 
          `"Y$b._             CPU: Pentium T4500 (2) @ 1.200GHz 
              `"""            GPU: Intel Mobile 4 Series Chipset 
                              Memory: 1748MiB / 5811MiB

I did not want to run Firefox as ESR, so I installed the flatpak, that worked just fine,
then, I wanted to install Brave browser as Snap; the install process works fine, but
it is not available on the programs menu (Cinnamon), I can run the snaps from the terminal just fine, but not from any gui.

I had the same issue on both Linux Mint and Linux Mint Debian edition, naturally
I posted my question on Mint’s forum.

All I got were answers on the lines of “snaps are crap”, “snaps are for idiots” and so on,
I am old enough to not be offended by it, so I moved to trying to learn Debian itself.

So, I ran into the same issue, Snaps are correctly installed, but they are not shown on the programs launcher / menu, I am thinking it is a Cinnamon DE issue. I did not have this issue on neither Fedora / Open Suse / any dnf based, nor in Arch / Endeavour / any pacman based distro.

My reasons (because someone is gonna ask) for using Snappies, Flatties and Imaggies, is because they are separated from the system, they are static versions and they update only when I want to do it. I use them as a fallback whenever the version from the repos goes kaput. That’s it, no politics here.

So, anyone else here running snaps on Debian? I will appreciate every comment.

Thanks

2 Likes

I am not running Debian at the moment, but I get the same issue on Kubuntu when running snaps, they don’t seem to pop into KRunner or applications menu. I found a tutorial that mentioned the following

ln -s /var/lib/snapd/desktop/applications/rubymine_rubymine.desktop .local/share/applications

Replace rubymine_rubymine with any .desktop file in /var/lib/snapd/desktop/applications and this will symlink it under .local/share/applications. Works for Plasma, not sure if it will fix this issue for your set up, I haven’t tested it.

1 Like

It did not worked ‘literally’ the same way for my set up, but, it made me catch up with what is going on,
the snaps platform is working fine, but, for some reason, when it installs a snap, it does not create the link for that in the programs menu, so, you have to go and grab the launchers from the snappies folder and copy them to the menu manually.

Maybe the packager does not consider them essential to the system or whatever.

Now, that was actually very helpful. I do not how to mark this as Solved, but it is.

Thanks man,

1 Like

Update:

Snaps are populating the menu, however, I am not able to set Brave snap as defaut browser in the system settings, when I try to run it from the CL, I get this,

WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
Gtk-Message: Failed to load module “xapp-gtk3-module”

I’m looking into it, Laters

Just in case: https://snapcraft.io/docs/installing-snap-on-debian

Look, let’s not get all tribal about this. For myself I am pragmatic in a lot of ways but there are three main reasons why I don’t like snaps as much as flatpaks. If Cannonical decides to address those flaws I would feel happy to call them the same and recommend them both.

  1. Snap confinement needs work. Apparmor is a hot mess and is not fit for the purpose. The simple fact you have to use so many snaps with the --classic parameter bears this out. That is one of the main concerns for me.
  2. The snap store. While I feel Cannonical thinks it is doing the right thing I also feel this is another farce like Ubuntu One services are. The idea that you have to have a single authority login to file bugs is insanity, and the store is kinda the same. It is the same for a snap. You want to get registered for the snap store, sign up with Ubuntu One there is no other option. That it is proprietary rubbish does not surprise me at all because Unbuntu One itself is proprietary rubbish. So yeah, that irks me a lot.
  3. But the thing that really irks me more than anything is the frigging use of loopback devices ON BOOT. Why? I mean just WHY!? You do not need to mount them all at boot why not just mount them at run time? But these days in the 21st century you don’t need to use a loopback devices at all. I have already talked about nbdkit and how it is a far superior solution to reading compressed files. I mean it just is. You can even have a compressed image read/writable. It is just awesome, really.

So I don’t think I am being unreasonable when I say I prefer flatpak to snaps. These are reasons I can and do prefer flatpaks over snaps. but I am only some random dude on the internet so make up your own minds.

On the topic of Brave you can install it directly from Brave repos if you want. Though I do concur that the added sandboxing is preferred.