About Gnome's airplane mode deal

Hi there,

I have been trying to use gnome on / off for a while now, it was the first desktop I got when I left windows and started distro hopping, because of win10 19.03, yeap, that was my last stop for me.

Anyway, I always found the behaviour of the automatic airplane-mode very, very annoying, it is the only desktop that does that, and I cannot understand why.

So, for the ones who do not know; when you turn wifi off, it automaticaly turns airplane-mode on, and then, when turning arplane-mode off again, wifi AND bt get on, and then you have to turn bt off again if you don’t want it. Only to repeat the ordeal every time you want to toggle the wifi or the bt, and again, when the system boots.

I still have no idea how to ‘fix’ this issue, that is the reason I am posting this, does anyone know how to do it?, but also, I am trying to understand the logic behind it.

I do not mean to hurt anyone’s feelings, but now I understand that this is not a bug, it would have been fixed by now, this is how it is supposed to work. and I just can’t bend my brain arround it.

Thank you and again, this is not a hate post, I really need to ask.

Cheers

Edit: BTW, I’m on Endeavour OS, in case someone knows a fix.

On modern computers Wifi and Bluetooth share the same hardware module so it’s an extra step for Gnome to remember to turn one of those off in software after re-enabling the hardware.

Same goes for why the Pinephone and Librem 5 have physical kill switches that turn both Wifi and Bluetooth on or off as a pair but not seperately.

Gnome should fix it given Bluetooth has reoccurring major vulnerabilities but if i’d guess that’s why it’s the way it is. If I knew Gnome I could be more help, maybe use a hotkey for a terminal command in the meantime?

That actually is a good explanation, yes, I found a few extensions that I think are meant to solve this, if it does not work, hotkeys it is.

And I agree, bt poses a way bigger thread than wifi, that it is why it did not make sense to just switch it back on. Endeavour OS does not install the bt module, only after, thru a greeter.

Thanks, I can start to make some sense of it.

Laters

The Bluetooth thing always annoyed me on Gnome. I always disable it, even the systemd service for it entirely.

That for sure is a solution, if you don’t even use bt, just thow it off the boat.

I found this extension

It seems to do the trick, It has been a few sessions now and so far so good. I leave it here so others can find it.

Laters

I do find the behavior weird and it gets annoying at times. But if you turn wifi on through the top-right drop-down menu while airplane mode is on, it’ll go away while bluetooth stays off.

I’m currently testing Mobian for the Pinephone and it uses Gnome as the DE.

If you disable wifi when bluetooth is disabled or disable bluetooth when wifi is disabled it enters airplane mode automatically which shuts off the cellular/mobile data. Good times.

Can it use extensions? try the one I shared up there. Seems to be working fine for me, it has been one day thou.

Laters.

1 Like